Internet Service & Networking
Home > LOEKELOE > COMPUTER STUFF > Internet Service & Networking > Knowledge Share - IPv6 Preview [BAB I]
Total Views: 29811 Share : Facebook ShareFacebook Twitter ShareTwitter Google+ ShareGoogle+
Page 2 of 56 |  < 1 2 3 4 5 6 7 >  Last ›

risnaini - 14/11/2011 10:40 AM
#21
Implementasi IPv6 di Cisco Router sebagai DHCP Server IPv6
Linknya Gan...
http://www.ip-stories.com/?p=786

During ID-IPv6 Task Force Event 30 October 2008 which is “Sosialisasi IPv6 & Hands On Traingin Dasar IPv6″, users able to have dual stack on their laptops. The DHCP server ran by Cisco Router 3725 with 12.3(4) T IOS version platform.

Trainer Today Cisco : Ade Yudha G (Cisco System), Christian (D-Net), Rahman Isnaini (Netsoft/IndoInternet).

Trainer Today Mikrotik : Niko (UfoAkses), Ervin A Taufik (IndoInternet).

Running Cisco as DHCP server for both IPv6 & IPv4 with NAT, configuration as below :

IPV6-GW#sh run
!
hostname IPV6-GW
!
ip subnet-zero
ip cef
!
!
no ip dhcp conflict logging
ip dhcp excluded-address 172.16.255.1
ip dhcp excluded-address 172.16.255.100
!
ip dhcp pool ipv4-postel
network 172.16.255.0 255.255.255.0
dns-server 202.159.32.2
domain-name ipv4.postel.go.id
netbios-node-type h-node
default-router 172.16.255.1
!
!
ip name-server 202.159.32.2
ip name-server 202.159.33.2
ip ips po max-events 100
ipv6 unicast-routing
ipv6 dhcp pool ipv6-postel
prefix-delegation 2404:170DEADDEAD::/64 0005000400F1A4D07003
prefix-delegation pool prefix-pool lifetime 1800 60
dns-server 2404:170:32::2
domain-name ipv6.postel.go.id
!
interface FastEthernet0/0
description IPV6-BACKBONE
ip address 202.53.252.50 255.255.255.252
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
ipv6 address 2404:170:251::AA/125
ipv6 enable
!
interface Serial0/0
no ip address
shutdown
clockrate 2000000
!
interface FastEthernet0/1
description DHCP-HOTSPOT-LAN
ip address 172.16.255.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
ipv6 address 2404:170DEADDEAD::1/64
ipv6 enable
ipv6 traffic-filter DHCP-OUT out
ipv6 nd other-config-flag
ipv6 dhcp server ipv6-postel
!
interface Serial0/1
ip address 10.10.10.10 255.255.255.252
ipv6 address 2008::1/64
ipv6 enable
clockrate 2000000
!
ip classless
ip route 0.0.0.0 0.0.0.0 202.53.252.49
!
no ip http server
no ip http secure-server
ip nat inside source list 50 interface FastEthernet0/0 overload
!
!
access-list 50 permit 172.16.255.0 0.0.0.255
ipv6 route ::/0 2404:170:251::A9
!
ipv6 access-list DHCP-OUT
remark FILTER-SECURE-POSTEL-IPV6-HOSTPOT
sequence 150 deny tcp any any range ftp-data telnet
sequence 151 deny tcp any any range 135 139
sequence 152 deny tcp any any range 161 162
sequence 153 deny tcp any any eq 6029
sequence 154 deny tcp any any range 67 68
sequence 155 deny tcp any any eq gopher
sequence 156 deny tcp any any eq finger
sequence 157 deny tcp any any eq www log
sequence 158 deny tcp any any eq 87
sequence 159 deny tcp any any eq sunrpc
sequence 160 deny tcp any any eq irc
sequence 161 deny tcp any any eq 372
sequence 162 deny tcp any any eq exec
sequence 163 deny tcp any any range login klogin
sequence 164 deny tcp any any eq cmd
sequence 165 deny tcp any any eq nntp
sequence 166 deny tcp any any eq uucp
sequence 167 deny tcp any any eq lpd
sequence 168 deny tcp any any eq 37
sequence 169 deny tcp any any eq 445
sequence 170 deny tcp any eq 445 any
sequence 171 deny tcp any any eq 450
sequence 172 deny tcp any any eq 1434
sequence 173 deny tcp any eq 1434 any
sequence 174 deny tcp any any eq 1524
sequence 175 deny tcp any any eq 2000
sequence 176 deny tcp any any range 2041 2049
sequence 177 deny udp any any range 135 netbios-ss
sequence 178 deny udp any any range snmp snmptrap
sequence 179 permit udp any any eq tftp
sequence 180 deny udp any any eq 1434
sequence 181 deny udp any eq 1434 any
sequence 182 deny udp any any eq time
sequence 183 deny udp any any eq tacacs
sequence 184 deny udp any any eq bootps
sequence 185 deny udp any any eq bootpc
sequence 186 deny udp any any eq sunrpc
sequence 187 deny udp any any eq 144
sequence 188 deny udp any any eq who
sequence 189 deny udp any any eq 515
sequence 190 deny udp any any eq rip
sequence 191 deny udp any any eq 27444
sequence 192 deny udp any any eq 31335
sequence 199 permit ipv6 any 2404:170DEAD::/48
sequence 500 deny ipv6 any any log
!
end
risnaini - 14/11/2011 10:57 AM
#22
Implementasi IPv6 di Windows XP secara Manual
http://www.ip-stories.com/?p=787
-----------------------------------

Due to ipv6 limitation configuration in Windows XP, in a IPv6 Network.
Once your windows XP assigned IPv6 by DHCP Server either dedicated IPv6 DHCP server (linux/unix) or Cisco Router (12.3 (4) T).

###########################################
NOTE :

Windows XP would not get IPv6 Address from DHCP server until it has IPv4 installed on as well either input manually or IPv4 DHCP server as well.
############################################

You’ll see no DNS installed supposed to be dynamically on your IPCONFIG /ALL.

This case will not happen in Vista as it supports IPv6 in fully configuration.
Here the way to add static DNS in your Windows XP

a. Make sure IPv6 Installed [IPv6 Install]
b. Follow this steps :

C:\Documents and Settings\a. rahman >isnaini netsh
>netshinterface ipv6
netsh interface >ipv6add dns “wireless network connection” 2404:170:32::2
Ok.

netsh interface >ipv6exit

C:\Documents and Settings\a. rahman >isnainiipconfig /all

Ethernet adapter Wireless Network Connection:

Connection-specific DNS Suffix . : hotspot-dea.indo.net.id
Description . . . . . . . . . . . : Intel(R) PRO/Wireless 3945ABG Network Connection
Physical Address. . . . . . . . . : 00-1F-3C-14-6E-25
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.0.88
Subnet Mask . . . . . . . . . . . : 255.255.255.0
IP Address. . . . . . . . . . . . : fe80::21f:3cff:fe14:6e25%6
Default Gateway . . . . . . . . . : 192.168.0.1
DHCP Server . . . . . . . . . . . : 192.168.0.1
DNS Servers . . . . . . . . . . . : 202.159.32.2
2404:170:32::2
OPiKdesign - 14/11/2011 11:20 AM
#23

OM MOD DAN ADMIN....
BISA GAK THREAD INI DI STICKY???!!!

:request :request :request :request :matabelo :matabelo :matabelo


-------------------------------------------
Tutorial Ubuntu Server...
Tutorial Failover Mikrotik dan External Proxy
Belajar IPv4 dan Subneting
Tutorial: Memisahkan Bandwidth Local (IIX) dan International (INTL) di Linux
Buat Kabel Console Null-Modem
Reset RB Mikrotik lewat Kabel Console

-------------------------------------------
Numpang Lapak:
Jasa Seting Mikrotik-External Server u/ warnet & Networking Engineering kelas Company
risnaini - 16/11/2011 11:08 AM
#24

Quote:
Original Posted By OPiKdesign
OM MOD DAN ADMIN....
BISA GAK THREAD INI DI STICKY???!!!

:request :request :request :request :matabelo :matabelo :matabelo


-------------------------------------------
Tutorial Ubuntu Server...
Tutorial Failover Mikrotik dan External Proxy
Belajar IPv4 dan Subneting
Tutorial: Memisahkan Bandwidth Local (IIX) dan International (INTL) di Linux
Buat Kabel Console Null-Modem
Reset RB Mikrotik lewat Kabel Console

-------------------------------------------
Numpang Lapak:
Jasa Seting Mikrotik-External Server u/ warnet & Networking Engineering kelas Company



Halo mas Opik, salam kenal.
Maksudnya ditebelin ya... (bener juga hehehe, abis belum kepikiran euy)..
risnaini - 29/11/2011 10:34 AM
#25
[Belajar IPv6] Implementasi BGP IPv6 di Quagga
Kalo punya Quagga, (soale cisco mahal hehe)
Berikut konfigurasi IPv6 dan BGP nya sekalian :

http://www.ip-stories.com/?p=1141


For a cheap IPv6 Solution using an OpenSource Router Engine.

BGP6 Configuration:
a. Remove default BGP ASN & Set Yours.
bgpd# configure terminal
bgpd(config)#no router bgp 7675
bgpd(config)# router bgp 100
bgpd#

b. Set Prefix-List for Filtering for Outgoing & Incoming IPv6 routes from/to Upstreams:

bgpd# conf t
bgpd(config)# ipv6 prefix-list IPv6-UPSTREAM-IN description ALLOW-IPv6-/32-LESS-ONLY
bgpd(config)# ipv6 prefix-list IPv6-UPSTREAM-IN seq 10 permit ::/0 le 32
bgpd(config)# ipv6 prefix-list IPv6-UPSTREAM-OUT seq 10 permit 2402:ac00::/32
bgpd(config)# ipv6 prefix-list IPv6-UPSTREAM-OUT seq 100 deny ::/0 le 128
bgpd(config)# end
bgpd#

c. Set Policy for Incoming/Outgoing IPv6 Routes

bgpd# conf t
bgpd(config)#
bgpd(config)# route-map IPv6-UP1-IN permit 10
bgpd(config-route-map)# match ipv6 address prefix-list IPv6-UPSTREAM-IN
bgpd(config-route-map)#end
bgpd(config)#
bgpd(config)# route-map IPv6-UP1-OUT permit 10
bgpd(config-route-map)# match ipv6 address prefix-list IPv6-UPSTREAM-OUT
bgpd(config-route-map)#end
bgpd(config)#
bgpd(config)# route-map IPv6-UP2-IN permit 10
bgpd(config-route-map)# match ipv6 address prefix-list IPv6-UPSTREAM-IN
bgpd(config-route-map)#end
bgpd(config)#
bgpd(config)# route-map IPv6-UP2-OUT permit 10
bgpd(config-route-map)# match ipv6 address prefix-list IPv6-UPSTREAM-OUT
bgpd(config-route-map)#end
bgpd(config)#

d. Set BGP6 Neighbors to Upstream 1 & Upstream 2:

bgpd(config)#router bgp 100
bgpd(config-router)# address-family ipv6
bgpd(config-router-af)#neighbor 2404:170:251::a:a:15 activate
bgpd(config-router-af)# neighbor 2404:170:251::a:a:15 remote-as 150
bgpd(config-router-af)#neighbor 2404:170:251::a:a:15 route-map IPv6-USPTREAM-IN in
bgpd(config-router-af)#neighbor 2404:170:251::a:a:15 route-map IPv6-UPSTREAM-OUT out
bgpd(config-router-af)#network 2402:ac00::/32
bgpd(config-router-af)#neighbor 2402DC60:251::a:a:15 activate
bgpd(config-router-af)# neighbor 2402DC60:251::a:a:15 remote-as 200
bgpd(config-router-af)#neighbor 2402DC60:251::a:a:15 route-map IPv6-USPTREAM-IN in
bgpd(config-router-af)#neighbor 2402DC60:251::a:a:15 route-map IPv6-UPSTREAM-OUT out
bgpd(config-router-af)#network 2402:ac00::/32
bgpd(config-router-af)#end
bgpd#

e. Check Your BGP connections:

bgpd# sh bgp summary
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
2404:170:251::a:a:15
4 150 927 17 0 0 0 00:00:01 4
2402DC0:251::a:a:15
4 200 927 17 0 0 0 00:00:01 3
Total number of neighbors 2

f. Cross Check Your Prefix on Your Upstream:

Upstream1#show bgp ipv6 neighbors 2404:170:251::A:A:16 routes
BGP table version is 3185444, local router ID is 202.53.251.195
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
>* 2402:AC00::/32 2404:170:251::A:A:16 0 0 200 i

Upstream1#show bgp ipv6 neighbors 2402DC60:251::A:A:16 routes
BGP table version is 7745271, local router ID is 118.91.224.100
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
>* 2402:AC00::/32 2402DC60:251::A:A:16 0 0 200 i

rgs
a. rahman isnaini r.sutan
risnaini - 29/11/2011 10:37 AM
#26
[Belajar IPv6] Implementasi BGP IPv6 di Juniper
Ini buat di Juniper Gan...
IPv6 di BGP.

Your Interface :
==========

admin@JunOS#show
description ***TO-BGP-PEER***;
vlan-id 8;
family inet6 {
address 2404:170:251::A:A:1A/126;
}
[edit interfaces ge-1/3/0 unit 8]

The Command : refer to http://www.ip-stories.com/


BGP Setting :
=========

admin@JunOS#show
type external;
neighbor 2404:170:251::A:A:19 {
description CUSTOMER-IPV6;
import IPv6-CUSTOMER-IMPORT;
export IPv6-CUSTOMER-EXPORT;
peer-as 3940;
}

[edit protocols bgp group eBGP-IPv6]

The command :
admin@JunOS# set type external [different ASN]
admin@JunOS# set neighbor 2404:170:251::A:A:19 import IPv6-CUSTOMER-IMPORT export IPv6-CUSTOMER-EXPORT peer-as 3940
admin@JunOS# commit

Policy Setting :
==========

admin@JunOS#
policy-statement IPv6-CUSTOMER-IMPORT {
from as-path ALL;
then accept;
}
policy-statement IPv6-CUSTOMER-EXPORT {
from as-path ALL;
then reject;
}

as-path ALL .*

[edit policy-options]

The command :

admin@JunOS# set policy-statement IPv6-CUSTOMER-IMPORT from as-path ALL

[edit policy-options]
admin@JunOS# set policy-statement IPv6-CUSTOMER-IMPORT then accept

[edit policy-options]
admin@JunOS# set policy-statement IPv6-CUSTOMER-EXPORT from as-path ALL

[edit policy-options]
admin@JunOS# set policy-statement IPv6-CUSTOMER-EXPORT then reject
admin@JunOS# set as-path ALL .*
admin@JunOS# commit

BGP Status :
========

admin@JunOS# run show bgp summary
Groups: 17 Peers: 18 Down peers: 4
Table Tot Paths Act Paths Suppressed History Damp State Pending
inet.0 1206977 309046 0 0 0
0 inet6.0 2416 2414 0 0 0
0 Peer AS InPkt OutPkt OutQ Flaps Last Up/Dwn State|#Active/Received/Damped…
2404:170:251::a:a:19 9340 1897 6 0 0 1:31 Establ
inet6.0: 2414/2416/0
risnaini - 29/11/2011 10:48 AM
#27
[Belajar IPv6] Implementasi IPv6 di OSPFv3
http://www.ip-stories.com/?p=565

Berikut contoh penerapan OSPFv3 dalam IPv6 connection route.

[code]
interface GigabitEthernet0/1.3
description INDONESIA EXHCHANGE GATEWAY - 1 [CYBER]
encapsulation dot1Q 3
ipv6 address 2404:170:251::41/126
ipv6 enable
ipv6 ospf 15 area 0.0.0.0
no snmp trap link-status

ipv6 router ospf 15
log-adjacency-changes
redistribute connected
redistribute static
[/code]
sentracolo - 29/11/2011 12:45 PM
#28

Hehe Uda nongol disini... Manstab dan berguna sekali artikelnya :addfriends
Semoga sukses Uda...

Satuju thread ini di Sticky ya Om Momod...


:2thumbup:2thumbup:2thumbup
X-Nitro - 01/12/2011 10:23 AM
#29

Semoga terus sharing2 ttg ipv6 di sini yah
X-Nitro - 01/12/2011 10:25 AM
#30

@TS, biar rapi kyknya mesti pake [CODE]ISI CONFIG ROUTER[/CODE]
OPiKdesign - 01/12/2011 10:27 AM
#31

sentracolo - 01/12/2011 05:50 PM
#32

Quote:
Original Posted By X-Nitro
Semoga terus sharing2 ttg ipv6 di sini yah


Terimakasih Om Momod atas persetujuan nya...

shakehand2shakehand2
vina8vina - 01/12/2011 06:44 PM
#33

yasalam matabelo:
ini dia yg ane tunggu tunggu, akhirnya ketemu juga trid nya D
makasih gan udah mau share \)
mudah2an berguna bagi siapapun \)
coba bisa di ajarin langsung dengan "Uda Rahman" Peace:
salam dari tim BNA ya uda D
cendol sent shakehand:
risnaini - 01/12/2011 10:34 PM
#34

Thanks Agan X-Nitro, Mas Opik dan Oom Mod.
Bisa begini tah rupanya hehe.

To agan Vina and SentraColo, perlu makan2 di cyber dak niy \)
Anyway, APNIC sedang kita koordinasikan satu IPv6 Test Flight sebelum Juni (mungkin di maret dan april) karena penetrasi IPv6 Indonesia masih rendah disisi end user.

BNA ikutan \)
risnaini - 01/12/2011 10:41 PM
#35
[Belajar IPv6] Implementasi IPv6 di Juniper Interface dan Static Route
Berikut gan..


[code]
Configured yes, under interface mode.
Belows example shows IPv4 & IPv6 at one sub interface [Dual Stack]

admin@JunOS# set family inet6 address 2404:170:251::A:A:1A/126

[edit interfaces ge-1/3/0 unit 4]
admin@JunOS# show
description ***TO-CUST***;
vlan-id 4;
family inet {
address 192.168.224.45/30;
}
family inet6 {
address 2404:170:251::A:A:1A/126;
}

[edit interfaces ge-1/3/0 unit 4]

admin@JunOS# run ping 2404:170:251::A:A:19
PING6(56=40+8+8 bytes) 2404:170:251::a:a:1a >– 2404:170:251::a:a:19
16 bytes from 2404:170:251::a:a:19, icmp_seq=0 hlim=64 time=1.082 ms
16 bytes from 2404:170:251::a:a:19, icmp_seq=1 hlim=64 time=0.871 ms
16 bytes from 2404:170:251::a:a:19, icmp_seq=2 hlim=64 time=1.377 ms

Set Default Route
==================

Configured under routing-Option.
Please re-ensure that Ipv6 Static Route “NOT” under static mode but under rib mode named inet6.0 [what ever you named it].

admin@JunOS# set rib inet6.0 static route 0::/0 next-hop 2404:170:251::A:A:19
[edit routing-options]
admin@JunOS#commit

admin@JunOS# show
interface-routes {
rib-group inet all-ribs;
}
rib inet6.0 {
static {
route 0::/0 next-hop 2404:170:251::A:A:19;
}
}

admin@JunOS# run traceroute 2001:200:0:8002:203:47ff:fea5:3085 no-resolve
traceroute6 to 2001:200:0:8002:203:47ff:fea5:3085 (2001:200:0:8002:203:47ff:fea5:3085) from 2404:170:251::a:a:1a, 30 hops max, 12 byte packets
1 2404:170:251::a:a:19 1.314 ms 1.49 ms 1.121 ms
2 2404:c000:4000:4514:7:3852:5:1 29.669 ms 1.326 ms 4.286 ms
3 2404:c000:0:1::5 3.332 ms 3.122 ms 1.599 ms
4 2001:7fa:0:1::ca28:a1db 283.406 ms 288.813 ms 280.211 ms
5 2001:218:0:6000::13d 281.033 ms 281.488 ms 284.32 ms
6 2001:218:0:2000::101 269.061 ms 272.352 ms 2001:218:0:2000::15a 291.264 ms
7 2001:218:0:2000::5 289.404 ms 2001:218:0:6000::116 283.702 ms 282.235 ms
8 2001:218:0:6000::116 284.39 ms 285.519 ms 2001:218:2000:5000::82 274.299 ms
9 2001:200:0:10::141 274.942 ms 2001:218:2000:5000::82 277.802 ms 277.253 ms
10 2001:200:0:11::66 273.719 ms 274.504 ms 272.959 ms
11 2001:200:0:12::74 273.844 ms 2001:200:0:11::66 275.37 ms 275.73 ms
12 2001:200:0:4803:212:e2ff:fe28:1ca2 277.486 ms 276.499 ms 2001:200:0:12::74 276.379 ms
13 2001:200:0:4803:212:e2ff:fe28:1ca2 281.574 ms 2001:200:0:8002:203:47ff:fea5:3085 275.133 ms 275.072 ms

[/code]

Linknya gan...
http://www.ip-stories.com/?p=1116
risnaini - 01/12/2011 10:45 PM
#36
[Belajar IPv6] Implementasi sederhana Firewall IPv6 di FreeBSD
# Simple Firewall :

[code]
(allow network 2404:170::/32 to any host)
ip6fw add 100 allow all from 2404:170::/32 to any in via fxp0

(allow network 2001:dc6::/32 to any host)
ip6fw add 200 allow all from 2001:dc6::/32 to any in via fxp0

(allow all ipv6 to host 2404:170:ee02::10)
ip6fw add 300 allow all from :: to 2404:170:ee02:ee02::10 in via fxp0

(deny other all traffic).
ip6fw add 1000 deny all from any to any in via fxp0
[/code]
bowie - 02/12/2011 07:22 AM
#37

ikutan Sundul biar tetap teratas \), ijin BookMark ya Gan \)
risnaini - 02/12/2011 07:27 AM
#38

Siap agan jatiasih... \)
Kayaknya udah sampai kantor nih.
yosdifamily - 02/12/2011 07:53 AM
#39

ane punya alamat IP kaya gini gan

10.13.103.11


ada situs yang nggak kebukak contohnya situs torrent
ada cara untuk ngatasin nya gan

ane make jaringan di kantor gan

pake server gitu ada solusi nggak gan,

maaf sebelumnya jika ane salah tempat buat nanya
sarbeni - 02/12/2011 08:53 AM
#40

Bantu sundul :addfriends

Quote:
Original Posted By risnaini
[Powerful - Mikrotik for Outdoor Here !]
====================

[benz@mikro6] > ipv6 address add address=2404:170:dead:dead::dead/126 interface=ETHERNET
failure: cannot advertise address with prefix length not equal to 64 (use advertise=no)
[benz@mikro6] > ipv6 address add address=2404:170:dead:dead::dead/126 interface=ETHERNET advertise=no

[benz@mikro6] > ipv6 address print
Flags: X - disabled, I - invalid, D - dynamic, G - global, L - link-local, M - multicast
# ADDRESS INTERFACE ADVERTISE
1 IG 2404:170:dead:dead::dead/126 ETHERNET no

route

[benz@mikro6] > ipv6 route add gateway=2404:170:dead:dead::deae
Page 2 of 56 |  < 1 2 3 4 5 6 7 >  Last ›
Home > LOEKELOE > COMPUTER STUFF > Internet Service & Networking > Knowledge Share - IPv6 Preview [BAB I]